分类 "jQuery" 下的文章

问题:使用fileupload如何跨域上传图片?

解决:跨域问题可以前端解决,也可以后端解决

方法:
方法一:配置fileupload

$('#fileupload').fileupload({
        url: config.getUrl()+"upload!upload.do",
        type:"POST",
        dataType:"json",
        autoUpload : true,
        acceptFileTypes: /(\.|\/)(jpe?g|png)$/i,
        formData: {model:1},
        forceIframeTransport: true,  # 实现跨域
        redirectParamName:"callUrl",
        redirect:"http://"+window.location.host+"/app/callupload.html?",  // 回调页面,接受回调

阅读全文

问题:如何使用jquery实现div的拖拽功能?

方法:

$(function() {
 //样式
 $("#drag").css({
     "position": "absolute",
     "top": "100px",
     "left": "100px",
     "border": "1px solid #789",
     "width": "150px",
     "height": "90px",
     "background": "#988f82",
     "cursor": "move"
 })

阅读全文

简介:简单的模态框代码

HTML:

<!-- 弹窗 -->
<div class="backdrop"></div>
<div class="modal-box" id="folder_modal">
    <div class="modal-content">
        <div class="modal-header">
            <label class="modal-title">移动到</label>
            <i class="fr modal-close fa fa-close"></i>
        </div>
        <div class="modal-body">
        </div>
        <div class="modal-footer">
            <button type="button" class="mt-button" id="submit_btn">确定</button>
            <button type="button" class="mt-button-light" id="cancel_btn">取消</button>
        </div>
    </div>
</div>

阅读全文

问题:在修改数据时,要根据数据对select选择框进行预设置数据
解决:使用jquery实现
方法:
一、使用后台语言进行判断
<select id="course">
<option value="2" {% if course == 2%}selected="selected"{%end%}>语文</option>
<option value="1" {% if course == 2%}selected="selected"{%end%}>数学</option>
<option value="3" {% if course == 2%}selected="selected"{%end%}>英语</option>
<option value="4" {% if course == 2%}selected="selected"{%end%}>物理</option>
<option value="5" {% if course == 2%}selected="selected"{%end%}>化学</option>
</select>
二、使用jquery进行判断并赋值
$("#course option").each(function(){
var course = $(this).val();
if(course == '{{ course }}'){
$("#course").val(course);
return false;
}
});

问题:使用jquery时出现$.browser is undefined的错误
解决:这是因为jquery 从 1.9 版开始,移除了 $.browser 和 $.browser.version , 取而代之的是 $.support 。
方法一:
将jquery更改为1.7的版本
方法二:将用到的$.browser更改为$.support